Wednesday, September 10, 2008

First run with support belt

I tried out the Gabrialla band today on my run. At first, it didn't help. Even walking the first half mile or so to warm up, I had ligament pain no matter how I adjusted it...high, low, middle. So I sucked it up and started running, and got a side stitch pretty quickly (I haven't had one of those in a LONG time, and never while running so slowly). I walked for another minute or two (during which I was passed by a male runner, and I was a little disheartened to realize I didn't even care), then just sucked it up and ran. A few minutes in I felt fine, no more ligament pain, and actually had a good, if slow, 4.5 miles. (Didn't help that my legs are cooked from a core class last night, apparently I've been neglecting training my hamstrings.) So not sure if the band helped, but it didn't hurt, and as much as things are probably going to change in the next few weeks, I bet I will end up liking it.

3 comments:

IVF Running Mama said...

Well, you might just want to start out wearing the belt on your runs and take it off if you don't need it. It's better than getting out there (like I did this past Sunday) and realize that you REALLY need it. Do you find it to be tight? I think I should have ordered a medium.

Clare said...

i kind of wish it was tighter actually...i got the medium. it's semi-adjustable i guess, but i have everything as tight as i can get it! it's good probably, don't want to squish the kid, and we have plenty of growing still to do. i'll keep wearing it just in case, like you say...it certainly doesn't hurt!

N.D. said...

ooh.. good to know!! Hope that you get used to it.